const regex = /^\s*function\s+([a-zA-Z$_][a-zA-Z\d$_]*)\s*\(/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*function\\s+([a-zA-Z$_][a-zA-Z\\d$_]*)\\s*\\(', '')
const str = `
function
\$\$
(z) {
if (z == true) {
console.log ("Something says Z is true");
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}