$re = '/^(?(DEFINE)(?\'dn\'[^\\\\\/:*"<>|\ ]+[^\\\\\/:*"<>|]*[^\\\\\/:*"<>|\.\ ]+)(?\'ds\'\\\\|\/))(?\'fn_path\'(?\'f_path\'(?&ds)?((\.{1,2}(?&ds))|((?&dn)(?&ds)))*)?(?\'fn\'(?&dn)))(?\'ext_dot\'\.(?\'ext\'asm))$/m';
$str = '.\\.\\../../../fil l/fill2.asm.asmfile.asm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);