#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?(DEFINE)(?'dn'[^\\\/:*"<>|\ ]+[^\\\/:*"<>|]*[^\\\/:*"<>|\.\ ]+)(?'ds'\\|\/))(?'fn_path'(?'f_path'(?&ds)?((\.{1,2}(?&ds))|((?&dn)(?&ds)))*)?(?'fn'(?&dn)))(?'ext_dot'\.(?'ext'asm))$"
Local $sString = ".\.\../../../fil l/fill2.asm.asmfile.asm" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")