import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?(DEFINE)(?'dn'[^\\\\\\/:*\"<>|\\ ]+[^\\\\\\/:*\"<>|]*[^\\\\\\/:*\"<>|\\.\\ ]+)(?'ds'\\\\|\\/))(?'fn_path'(?'f_path'(?&ds)?((\\.{1,2}(?&ds))|((?&dn)(?&ds)))*)?(?'fn'(?&dn)))(?'ext_dot'\\.(?'ext'asm))$";
final String string = ".\\.\\../../../fil l/fill2.asm.asmfile.asm\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}