const regex = /^(?(DEFINE)(?'dn'[^\\\/:*"<>|\ ]+[^\\\/:*"<>|]*[^\\\/:*"<>|\.\ ]+)(?'ds'\\|\/))(?'fn_path'(?'f_path'(?&ds)?((\.{1,2}(?&ds))|((?&dn)(?&ds)))*)?(?'fn'(?&dn)))(?'ext_dot'\.(?'ext'asm))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?(DEFINE)(?\'dn\'[^\\\\\\\/:*"<>|\\ ]+[^\\\\\\\/:*"<>|]*[^\\\\\\\/:*"<>|\\.\\ ]+)(?\'ds\'\\\\|\\\/))(?\'fn_path\'(?\'f_path\'(?&ds)?((\\.{1,2}(?&ds))|((?&dn)(?&ds)))*)?(?\'fn\'(?&dn)))(?\'ext_dot\'\\.(?\'ext\'asm))$', 'gm')
const str = `.\\.\\../../../fil l/fill2.asm.asmfile.asm
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}