import Foundation
let pattern = #"\b(?P<date>(?P<day>3[0-1]|[0-2]?[\d])(?P<separator>\/|\-|\.)(?P<month>1[0-2]|[0-1]?[\d])\3(?P<year>[\d]{4}|[\d]{2}))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"este es el 22/11/2015 o el 8/2/1982 o el 9-5-2012 o tal vez el 10.10.15 mas que 9-5-12 tdo"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)