using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?P<date>(?P<day>3[0-1]|[0-2]?[\d])(?P<separator>\/|\-|\.)(?P<month>1[0-2]|[0-1]?[\d])\3(?P<year>[\d]{4}|[\d]{2}))";
string input = @"este es el 22/11/2015 o el 8/2/1982 o el 9-5-2012 o tal vez el 10.10.15 mas que 9-5-12 tdo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}