import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?P<date>(?P<day>3[0-1]|[0-2]?[\\d])(?P<separator>\\/|\\-|\\.)(?P<month>1[0-2]|[0-1]?[\\d])\\3(?P<year>[\\d]{4}|[\\d]{2}))";
final String string = "este es el 22/11/2015 o el 8/2/1982 o el 9-5-2012 o tal vez el 10.10.15 mas que 9-5-12 tdo";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}