re = /node_modules\/(?!@devplat\/bestie-privacy.*|whatwg-fetch).*/m
str = 'node_modules/whatwg-fetch/fetch.js
node_modules/@devplat/bestie-privacyprefences-ts-client/dist/index.js
node_modules/@babel/cli/index.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end