import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "node_modules\\/(?!@devplat\\/bestie-privacy.*|whatwg-fetch).*";
final String string = "node_modules/whatwg-fetch/fetch.js\n"
+ "node_modules/@devplat/bestie-privacyprefences-ts-client/dist/index.js\n"
+ "node_modules/@babel/cli/index.js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}