#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)node_modules\/(?!@devplat\/bestie-privacy.*|whatwg-fetch).*"
Local $sString = "node_modules/whatwg-fetch/fetch.js" & @CRLF & _
"node_modules/@devplat/bestie-privacyprefences-ts-client/dist/index.js" & @CRLF & _
"node_modules/@babel/cli/index.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")