$re = '/node_modules\/(?!@devplat\/bestie-privacy.*|whatwg-fetch).*/m';
$str = 'node_modules/whatwg-fetch/fetch.js
node_modules/@devplat/bestie-privacyprefences-ts-client/dist/index.js
node_modules/@babel/cli/index.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);