# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\b(\.\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\b){3}"
test_str = ("192.168.178.1\n"
"192.168.178.2\n"
"200.200.200.200\n"
"255.255.255.255\n\n"
" 200.200.200.200\n"
"200.200.200.200 \n"
"200.200.256.200\n"
"200.200.200.200.\n"
"200.200.200\n"
"200.200.200.2d0\n"
"100.100.020.100\n"
"-1.0.0.0\n"
"200000000000000000000000000000000000000000000000000000000000000000000000000000.200.200.200\n\n"
"Insgesamt 13")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.