use strict;
my $str = '192.168.178.1
192.168.178.2
200.200.200.200
255.255.255.255
200.200.200.200
200.200.200.200
200.200.256.200
200.200.200.200.
200.200.200
200.200.200.2d0
100.100.020.100
-1.0.0.0
200000000000000000000000000000000000000000000000000000000000000000000000000000.200.200.200
Insgesamt 13';
my $regex = qr/\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\b(\.\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\b){3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}