import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\\b(\\.\\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\\b){3}";
final String string = "192.168.178.1\n"
+ "192.168.178.2\n"
+ "200.200.200.200\n"
+ "255.255.255.255\n\n"
+ " 200.200.200.200\n"
+ "200.200.200.200 \n"
+ "200.200.256.200\n"
+ "200.200.200.200.\n"
+ "200.200.200\n"
+ "200.200.200.2d0\n"
+ "100.100.020.100\n"
+ "-1.0.0.0\n"
+ "200000000000000000000000000000000000000000000000000000000000000000000000000000.200.200.200\n\n"
+ "Insgesamt 13";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}