package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\b(\.\b(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\b){3}`)
var str = `192.168.178.1
192.168.178.2
200.200.200.200
255.255.255.255
200.200.200.200
200.200.200.200
200.200.256.200
200.200.200.200.
200.200.200
200.200.200.2d0
100.100.020.100
-1.0.0.0
200000000000000000000000000000000000000000000000000000000000000000000000000000.200.200.200
Insgesamt 13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}