use strict;
my $str = 'HKEY_USERS\\S-1-5-21-4238271725-2374787876-508243797-1000_CLASSES\\Local Settings\\MuiCache\\108\\A7EAB198\\@%SystemRoot%\\System32\\bthserv.dll,-102';
my $regex = qr/HKEY_USERS\\[^\\]+Classes\\/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}