package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)HKEY_USERS\\[^\\]+Classes\\`)
var str = `HKEY_USERS\S-1-5-21-4238271725-2374787876-508243797-1000_CLASSES\Local Settings\MuiCache\108\A7EAB198\@%SystemRoot%\System32\bthserv.dll,-102`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}