#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)HKEY_USERS\\[^\\]+Classes\\"
Local $sString = "HKEY_USERS\S-1-5-21-4238271725-2374787876-508243797-1000_CLASSES\Local Settings\MuiCache\108\A7EAB198\@%SystemRoot%\System32\bthserv.dll,-102"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")