using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HKEY_USERS\\[^\\]+Classes\\";
string input = @"HKEY_USERS\S-1-5-21-4238271725-2374787876-508243797-1000_CLASSES\Local Settings\MuiCache\108\A7EAB198\@%SystemRoot%\System32\bthserv.dll,-102";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}