re = /(
\(
# Match all but characters `\`, `(` or `)`
(?> [^\\()]
| \\.
| (?1)
)*
\)
)
/x
str = 'SHOULD MATCH:
()
(())
((()))
(\\() (\\))
(\\(\\)\\)\\)\\))
SHOULD NOT MATCH:
)
(
((((\\)\\)\\)\\)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end