package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(
\(
# Match all but characters `\`, `(` or `)`
(?> [^\\()]
| \\.
| (?1)
)*
\)
)
`)
var str = `SHOULD MATCH:
()
(())
((()))
(\() (\))
(\(\)\)\)\))
SHOULD NOT MATCH:
)
(
((((\)\)\)\)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}