$re = '/(
\(
# Match all but characters `\`, `(` or `)`
(?> [^\\\\()]
| \\\\.
| (?1)
)*
\)
)
/x';
$str = 'SHOULD MATCH:
()
(())
((()))
(\\() (\\))
(\\(\\)\\)\\)\\))
SHOULD NOT MATCH:
)
(
((((\\)\\)\\)\\)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);