using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(
\(
# Match all but characters `\`, `(` or `)`
(?> [^\\()]
| \\.
| (?1)
)*
\)
)
";
string input = @"SHOULD MATCH:
()
(())
((()))
(\() (\))
(\(\)\)\)\))
SHOULD NOT MATCH:
)
(
((((\)\)\)\)
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}