import Foundation
let pattern = #"^https?:\/\/(www\.)?photos18\.com\/?((sort\/[\w\d]+)|(v\/[\w\d]+)|(cat\/\d)|)(\?.*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.photos18.com/sort/likes?page=10
https://www.photos18.com/sort/likes
https://www.photos18.com/v/vNq0G
https://www.photos18.com/v/vNq0G?page=10&perpage=100
https://www.photos18.com/cat/1
https://www.photos18.com/cat/1?page=10
https://www.photos18.com/?page=10&perpage=100
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)