import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(www\\.)?photos18\\.com\\/?((sort\\/[\\w\\d]+)|(v\\/[\\w\\d]+)|(cat\\/\\d)|)(\\?.*)?";
final String string = "https://www.photos18.com/sort/likes?page=10\n"
+ "https://www.photos18.com/sort/likes\n"
+ "https://www.photos18.com/v/vNq0G\n"
+ "https://www.photos18.com/v/vNq0G?page=10&perpage=100\n"
+ "https://www.photos18.com/cat/1\n"
+ "https://www.photos18.com/cat/1?page=10\n"
+ "https://www.photos18.com/?page=10&perpage=100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}