#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(www\.)?photos18\.com\/?((sort\/[\w\d]+)|(v\/[\w\d]+)|(cat\/\d)|)(\?.*)?"
Local $sString = "https://www.photos18.com/sort/likes?page=10" & @CRLF & _
"https://www.photos18.com/sort/likes" & @CRLF & _
"https://www.photos18.com/v/vNq0G" & @CRLF & _
"https://www.photos18.com/v/vNq0G?page=10&perpage=100" & @CRLF & _
"https://www.photos18.com/cat/1" & @CRLF & _
"https://www.photos18.com/cat/1?page=10" & @CRLF & _
"https://www.photos18.com/?page=10&perpage=100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")