package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(www\.)?photos18\.com\/?((sort\/[\w\d]+)|(v\/[\w\d]+)|(cat\/\d)|)(\?.*)?`)
var str = `https://www.photos18.com/sort/likes?page=10
https://www.photos18.com/sort/likes
https://www.photos18.com/v/vNq0G
https://www.photos18.com/v/vNq0G?page=10&perpage=100
https://www.photos18.com/cat/1
https://www.photos18.com/cat/1?page=10
https://www.photos18.com/?page=10&perpage=100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}