import Foundation
let pattern = #"\Dshared\Dprograms\D6\Dlessons\D\d{2,6}\Dslide_shows$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/shared/programs/6/lessons/1126/slide_shows
/shared/programs/6/lessons/1130/slide_shows
/shared/programs/6/lessons/965/slide_shows
/shared/programs/6/lessons/963/slide_shows
/shared/programs/6/lessons/965/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/1126/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/964/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/944/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/963/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/970/slide_shows
\Dshared\Dprograms\D6\Dlessons\D11\d{2}\Dslide_shows$
\Dshared\Dsections\D\d{3,5}\D.{1,10}[=]{0,1}[program_id]*\D{0,1}109
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)