using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\Dshared\Dprograms\D6\Dlessons\D\d{2,6}\Dslide_shows$";
string input = @"/shared/programs/6/lessons/1126/slide_shows
/shared/programs/6/lessons/1130/slide_shows
/shared/programs/6/lessons/965/slide_shows
/shared/programs/6/lessons/963/slide_shows
/shared/programs/6/lessons/965/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/1126/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/964/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/944/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/963/slide_shows
https://subscriptions.teachtci.com/shared/programs/6/lessons/970/slide_shows
\Dshared\Dprograms\D6\Dlessons\D11\d{2}\Dslide_shows$
\Dshared\Dsections\D\d{3,5}\D.{1,10}[=]{0,1}[program_id]*\D{0,1}109";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}