#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\Dshared\Dprograms\D6\Dlessons\D\d{2,6}\Dslide_shows$"
Local $sString = "/shared/programs/6/lessons/1126/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/1130/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/965/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/963/slide_shows" & @CRLF & _
"/shared/programs/6/lessons/965/slide_shows" & @CRLF & _
"" & @CRLF & _
"https://subscriptions.teachtci.com/shared/programs/6/lessons/1126/slide_shows" & @CRLF & _
"https://subscriptions.teachtci.com/shared/programs/6/lessons/964/slide_shows" & @CRLF & _
"https://subscriptions.teachtci.com/shared/programs/6/lessons/944/slide_shows" & @CRLF & _
"https://subscriptions.teachtci.com/shared/programs/6/lessons/963/slide_shows" & @CRLF & _
"https://subscriptions.teachtci.com/shared/programs/6/lessons/970/slide_shows" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\Dshared\Dprograms\D6\Dlessons\D11\d{2}\Dslide_shows$" & @CRLF & _
"\Dshared\Dsections\D\d{3,5}\D.{1,10}[=]{0,1}[program_id]*\D{0,1}109"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")