import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\Dshared\\Dprograms\\D6\\Dlessons\\D\\d{2,6}\\Dslide_shows$";
final String string = "/shared/programs/6/lessons/1126/slide_shows\n"
+ "/shared/programs/6/lessons/1130/slide_shows\n"
+ "/shared/programs/6/lessons/965/slide_shows\n"
+ "/shared/programs/6/lessons/963/slide_shows\n"
+ "/shared/programs/6/lessons/965/slide_shows\n\n"
+ "https://subscriptions.teachtci.com/shared/programs/6/lessons/1126/slide_shows\n"
+ "https://subscriptions.teachtci.com/shared/programs/6/lessons/964/slide_shows\n"
+ "https://subscriptions.teachtci.com/shared/programs/6/lessons/944/slide_shows\n"
+ "https://subscriptions.teachtci.com/shared/programs/6/lessons/963/slide_shows\n"
+ "https://subscriptions.teachtci.com/shared/programs/6/lessons/970/slide_shows\n\n\n\n"
+ "\\Dshared\\Dprograms\\D6\\Dlessons\\D11\\d{2}\\Dslide_shows$\n"
+ "\\Dshared\\Dsections\\D\\d{3,5}\\D.{1,10}[=]{0,1}[program_id]*\\D{0,1}109";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}