$re = '/(«[a-z])/';
$str = '«el taller del traductor"';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;