using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(«[a-z])";
string substitution = @"\U$1";
string input = @"«el taller del traductor""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}