const regex = /(«[a-z])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(«[a-z])', '')
const str = `«el taller del traductor"`;
const subst = `\U$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);