#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(«[a-z])"
Local $sString = "«el taller del traductor""
Local $sSubst = "\U$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)