$re = '/( ?.)\1{2,}/';
$str = 'llllllll
kkkkkkk
llll
fflllllllllll
lllll
llllllllllll
zoolosss~~~~~~~~~~~~!!!!!!!!!!!!!!!!!!';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;