const regex = /( ?.)\1{2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( ?.)\\1{2,}', 'g')
const str = `llllllll
kkkkkkk
llll
fflllllllllll
lllll
llllllllllll
zoolosss~~~~~~~~~~~~!!!!!!!!!!!!!!!!!!`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);