use strict;
my $str = 'llllllll
kkkkkkk
llll
fflllllllllll
lllll
llllllllllll
zoolosss~~~~~~~~~~~~!!!!!!!!!!!!!!!!!!';
my $regex = qr/( ?.)\1{2,}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";