#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "( ?.)\1{2,}"
Local $sString = "llllllll" & @CRLF & _
"kkkkkkk" & @CRLF & _
"llll" & @CRLF & _
"fflllllllllll" & @CRLF & _
"lllll" & @CRLF & _
"" & @CRLF & _
"llllllllllll" & @CRLF & _
"zoolosss~~~~~~~~~~~~!!!!!!!!!!!!!!!!!!"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)