package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((([a-z]\[[^\]]+\])(.{1}))?(\s*\=\>\s*)((([a-z]\[[^\]]+\])|([a-z].))(.{1})([A-Z]?)))?(\s*\/\/.*)?`)
var str = `// Алгоритм умножения. Формат ленты: [*]1111#111=*
// Множество: Q; Начальное значение: q[0]; Конечное значение: q*;
// Символ пустой ячейки: _; Символ перехода влево: L; Символ перехода вправо: R
q[0]1 => q[0]1R //2312312323
q[0]# => q[1]#R
q[0]* => q[0]*R
q[1]1 => q[2]aR
q[2]1 => q[2]1L
q[2]# => q[3]#L
q[2]= => q[2]=L
q[2]a => q[2]aL
q[3]1 => q[4]aR
q[3]a => q[3]aL
q[3]* => q[6]*R
q[4]1 => q[4]1R
q[4]# => q[4]#R
q[4]= => q[4]=R
q[4]a => q[4]aR
q[4]* => q[5]1R
q[5]_ => q[2]*L
q[6]# => q[7]#R
q[6]a => q[6]1R
q[7]1 => q[2]aR
q[7]= => q[8]=L
q[7]a => q[7]aR
q[8]# => q*#
q[8]a => q[8]1L`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}