// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((<([a-zA-Z0-9]*:)*matchNode[^>]*)\/\s*>)|(((<([a-zA-Z0-9]*:)*matchNode[\s\S]*?)>(([\s\S]*?)))<\/([a-zA-Z0-9]*:)*matchNode>)").unwrap();
let string = "<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<root xmlns:xx12=\"www.example.com\">
<xx12:matchNode so=\"what\">also matched</xx12:matchNode>
<matchNode/>
<matchNode>matched</matchNode>
<xx12:matchNode/>
<unmatchNode>
</unmatchNode>
<xx12:matchNode>also matched</xx12:matchNode>
<matchNode attr=\"12\" test=\"false\">
matched
</matchNode>
</root>";
let substitution = "$2$6>(obfuscated...)</$3$7matchNode>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}