const regex = /((<([a-zA-Z0-9]*:)*matchNode[^>]*)\/\s*>)|(((<([a-zA-Z0-9]*:)*matchNode[\s\S]*?)>(([\s\S]*?)))<\/([a-zA-Z0-9]*:)*matchNode>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<([a-zA-Z0-9]*:)*matchNode[^>]*)\\\/\\s*>)|(((<([a-zA-Z0-9]*:)*matchNode[\\s\\S]*?)>(([\\s\\S]*?)))<\\\/([a-zA-Z0-9]*:)*matchNode>)', 'g')
const str = `<?xml version="1.0" encoding="UTF-8"?>
<root xmlns:xx12="www.example.com">
<xx12:matchNode so="what">also matched</xx12:matchNode>
<matchNode/>
<matchNode>matched</matchNode>
<xx12:matchNode/>
<unmatchNode>
</unmatchNode>
<xx12:matchNode>also matched</xx12:matchNode>
<matchNode attr="12" test="false">
matched
</matchNode>
</root>`;
const subst = `$2$6>(obfuscated...)</$3$7matchNode>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);