package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((<([a-zA-Z0-9]*:)*matchNode[^>]*)\/\s*>)|(((<([a-zA-Z0-9]*:)*matchNode[\s\S]*?)>(([\s\S]*?)))<\/([a-zA-Z0-9]*:)*matchNode>)`)
var str = `<?xml version="1.0" encoding="UTF-8"?>
<root xmlns:xx12="www.example.com">
<xx12:matchNode so="what">also matched</xx12:matchNode>
<matchNode/>
<matchNode>matched</matchNode>
<xx12:matchNode/>
<unmatchNode>
</unmatchNode>
<xx12:matchNode>also matched</xx12:matchNode>
<matchNode attr="12" test="false">
matched
</matchNode>
</root>`
var substitution = "$2$6>(obfuscated...)</$3$7matchNode>"
fmt.Println(re.ReplaceAllString(str, substitution))
}