# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((<([a-zA-Z0-9]*:)*matchNode[^>]*)\/\s*>)|(((<([a-zA-Z0-9]*:)*matchNode[\s\S]*?)>(([\s\S]*?)))<\/([a-zA-Z0-9]*:)*matchNode>)"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<root xmlns:xx12=\"www.example.com\">\n"
" <xx12:matchNode so=\"what\">also matched</xx12:matchNode>\n"
" <matchNode/>\n"
" <matchNode>matched</matchNode>\n"
" <xx12:matchNode/>\n"
" <unmatchNode>\n"
" </unmatchNode>\n"
" <xx12:matchNode>also matched</xx12:matchNode>\n"
" <matchNode attr=\"12\" test=\"false\">\n"
" matched\n"
" </matchNode>\n"
"</root>")
subst = "$2$6>(obfuscated...)</$3$7matchNode>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.