import Foundation
let pattern = ##"(^|\s)(?!\b(?:basic|studio|asp|v[bs]|c\#)\.net)(\w+)(?:\.co\.[a-z]{2}|\.[a-z]{2,6})\b"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"site.org asp.net dsgsvgs somedomain.com sdbbdsb vb.net otherdomain.org vs.net wax.museum somesite.net vb.net micro.co.uk sdbsdbssd asp.co.uk visualbasic.co.hk ASP.net visualstudio.co.jp ddddddd visualbasic.net visual basic.net visual studio.net uuu. www.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)