$re = '/(^|\s)(?!\b(?:basic|studio|asp|v[bs]|c\#)\.net)(\w+)(?:\.co\.[a-z]{2}|\.[a-z]{2,6})\b/i';
$str = 'site.org asp.net dsgsvgs somedomain.com sdbbdsb vb.net otherdomain.org vs.net wax.museum somesite.net vb.net micro.co.uk sdbsdbssd asp.co.uk visualbasic.co.hk ASP.net visualstudio.co.jp ddddddd visualbasic.net visual basic.net visual studio.net uuu. www.com';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;