const regex = /(^|\s)(?!\b(?:basic|studio|asp|v[bs]|c\#)\.net)(\w+)(?:\.co\.[a-z]{2}|\.[a-z]{2,6})\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)(?!\\b(?:basic|studio|asp|v[bs]|c\\#)\\.net)(\\w+)(?:\\.co\\.[a-z]{2}|\\.[a-z]{2,6})\\b', 'gi')
const str = `site.org asp.net dsgsvgs somedomain.com sdbbdsb vb.net otherdomain.org vs.net wax.museum somesite.net vb.net micro.co.uk sdbsdbssd asp.co.uk visualbasic.co.hk ASP.net visualstudio.co.jp ddddddd visualbasic.net visual basic.net visual studio.net uuu. www.com`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);