# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|\s)(?!\b(?:basic|studio|asp|v[bs]|c\#)\.net)(\w+)(?:\.co\.[a-z]{2}|\.[a-z]{2,6})\b"
test_str = "site.org asp.net dsgsvgs somedomain.com sdbbdsb vb.net otherdomain.org vs.net wax.museum somesite.net vb.net micro.co.uk sdbsdbssd asp.co.uk visualbasic.co.hk ASP.net visualstudio.co.jp ddddddd visualbasic.net visual basic.net visual studio.net uuu. www.com"
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.