re = /(?: ([a-zA-Z0-9]+))|(?: :(.+))?/
str = ' haaaa heu hii hoooo huuu
allo pateee :hello jhsdfhu
:allo, les potes comment va ?
a b c d e f :allo, ok !&*8? -_=% :okok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end